Ofimatica

PRACTICA 14 OBTENCION DE NUEVAS FECHAS El ejercicio consiste en obtener nuevas fechas a partir de una fecha actual, o una fecha predeterminada. A partir de una de esas fechas y mediante la utilizacion de un Control de numeros, vamos a determinar cuantas nuevas fechas queremos obtener, en este caso optamos como maximo 31 y mediante una Barra de desplazamiento, vamos a determinar cuantos dias se agregan entre fecha y fecha a partir de la fecha inicio. Tendra una separacion maxima entre fechas de 365 dias, es decir tendremos como maximo 31 fechas que representan 31 anos de fechas.

A partir de esas nuevas fechas se obtendran: a) El dia a que corresponden esas fechas b) El numero de semana que corresponde a cada fecha, teniendo en cuenta que el ano tiene 52 semanas. c) Como se desglosa la fecha en Dia-Mes-Ano. d) Dias laborables entre fecha y fecha. e) Total de dias considerados entre todas las fechas. f) Total de dias laborables, referido al total de dias. g) Total de dias no laborables. Al tener incorporadas todas la formulas, estas soluciones se efectuaran en forma automatica, variando, solamente a traves de los elementos de control la cantidad de fechas, y cantidad

Lo sentimos, pero las muestras de ensayos completos están disponibles solo para usuarios registrados

Elija un plan de membresía
de dias entre ellas.

Se emplearon las funciones de fechas correspondientes, combinadas con otras funciones de logica e informacion, aplicando tambien a las celdas Formatos condicionales Todo esto permite desarrollar el total de fechas (31), o menos sin que se produzca ningun error al respecto. Para desarrollar el presente ejercicio, primero creamos un area de trabajo conformado por el rango A1:I38. En este rango adoptado permite desarrollar la planilla al maximo, es decir obtener 31 nuevas fechas, en este caso optamos por obtener 20, para permitir observar las funciones que se aplicaron al no desarrollar la operacion al maximo.

Una ves realizadas todas las operaciones, se obtiene el resultado que se muestra en la siguiente planilla que se ira desarrollando y explicando paso por paso. HOJA DE CALCULO 1 PRACTICA 14 A 1 2 3 4 5 6 7 8 9 1 2 20 Fecha 97 Dia Semana 34 10 24 51 13 27 3 17 44 5 19 47 9 36 Dia 22 27 4 9 14 20 26 1 6 11 18 24 29 3 11 16 21 26 3 8 Mes 8 11 3 6 9 12 3 7 10 1 4 7 10 2 5 8 11 2 6 9 Ano 2002 2002 2003 2003 2003 2003 2004 2004 2004 2005 2005 2005 2005 2006 2006 2006 2006 2007 2007 2007 Dias labor. 70 69 69 69 69 70 70 69 69 69 69 69 70 70 69 69 69 69 69 70 Fecha Actual 24/07/02 Fecha

Opcional 17/05/02 Total dias considerar Total dias laborab. Total dias no labor. a 1. 941 1. 386 555 B C D E F G H I 22-Ago-02 jueves 04-Mar-03 martes 09-Jun-03 lunes 20-Dic-03 sabado 26-Mar-04 viernes 01-Jul-04 jueves 11-Ene-05 martes 18-Abr-05 lunes 29-Oct-05 sabado 03-Feb-06 viernes 11-May-06 jueves 21-Nov-06 martes 26-Feb-07 lunes 08-Sep-07 sabado 27-Nov-02 miercoles 48 10 3 11 4 12 5 13 6 14 7 15 8 16 9 17 10 18 11 19 12 20 13 21 14 22 15 23 16 24 17 25 18 26 19 27 20 14-Sep-03 domingo 38 06-Oct-04 miercoles 41 24-Jul-05 domingo 31 16-Ago-06 miercoles 33 03-Jun-07 domingo 23

EJECUCION Celda C2: esa celda se destina para incorporar una fecha opcional, es decir una fecha de inicio para obtener las nuevas fechas. Celda C4: en esta celda se incluye la funcion HOY (), es decir en esa celda se incorpora la fecha actual. Celdas A5:A6: en estas celdas se incorpora un Control de numeros. Ir a Menu VIEW, TOOLBARS, FORMS; despues presionar sobre el icono SPINNER HOJA DE CALCULO 2 PRACTICA 14 Clic con el boton derecho del Mouse sobre el icono de spinner que se dibujo en la hoja Seleccionar Format Control Control Valor minimo 0 Valor maximo 31 Incremento 1 Vincular con la elda $B$6 Celda B6: en esta celda se incorporan los numeros como maximo 31 a traves del Control de numeros. Esto determina que cantidad de nuevas fechas a traves de una inicial adoptamos. Celda E6: se incorpora en esta en esta celda una Barra de desplazamiento Ir a Menu VIEW, TOOLBARS, FORMS; despues presionar sobre el icono SCROLL BAR Clic con el boton derecho del Mouse sobre el icono de scroll bar que se dibujo en la hoja Seleccionar Format Control Control Valor minimo 0 Valor maximo 365 Incremento 1 Vincular con la celda $D$6

Celda D6: en esta celda se incorpora el incremento de dias que se agregan entre fecha y fecha, a traves de la Barra de desplazamiento, con un maximo de 365 Celda A8=SI(B6>0;1;””) En esta celda se emplea la funcion logica SI, en donde se establece que en caso de que el valor de la celda B6 sea mayor que cero, es decir, obtener nuevas fechas, coloque el numero 1, en caso contrario celda vacia “”. En esta celda se aplico tambien Formato condicional en la celda, para que presente una textura diferente en caso de incorporar un numero que establece las nuevas fechas.

Como aplicar un Formato condicional a la celda A8 Menu Format, Seleccionar conditional Formating Cells Value—- Mayor que—– B9 Pulsar Format, Seleccionar y elegir un color en Trama y Fuente. Trasladar este Formato condicional de celda hasta la celda A38. Vale aclarar que se adopto la condicion Mayor que B9 por cuanto la columna B se encuentra en toda su extension B8:B38 en blanco, igual criterio como se podra observar, relacionado a la columna B se adopto en otras columnas que se aplico en sus celdas Formato condicional de celdas Celda A9=SI(ESERROR(SI(A8+10;$C$2;$C$4);C8));””; DIAS.

LAB(SI($C$2>0;$C$2;$C$4);C8)) En este caso la funcion empleada es DIAS. LAB, obteniendose por aplicacion de la misma, los dias laborables entre dos fechas determinadas, en este caso entre la fecha de C8 y la fecha opcional en caso de optar, caso contrario, toma fecha actual, esta opcion lo da la funcion SI En la segunda parte de la formula se adopto el mismo criterio que en las celdas anteriores, anidando la funcion ESERROR, mediante la funcion SI Celda I 9=SI(ESERROR(DIAS. LAB((C8+1);C9));””; DIAS. LAB((C8+1);C9)) En este caso se aplico la misma funcion para calcular los dias laborables entre la fecha de la celda C8 y celda C9.

A la fecha de la celda C8, se le suma un dia, por cuanto a la fecha propiamente dicha se calcula en la celda I 8 La funcion SI y ESERROR, se aplican con el mismo criterio empleado anteriormente. Los dias laborables determinados, corresponden, por reduccion de dias sabados y domingos. El resto de dias no laborables por ano, no se incluyen en el argumento de feriados por ano. Celda H3=SI($B$6=0;””;1+$B$6*$D$6) En esta celda se calcula el total de dias a considerar, es decir la cantidad de fechas a obtener,celda B6 a la que se agrega la fecha origen, multiplicado por la diferencia de dias, celda D6.

Se emplea la funcion SI, para obtener celda vacia en caso de optar por no obtener nuevas fechas. Celda H4=SI(C8=””;””;DIAS. LAB(SI($C$2>0;$C$2;$C$4);(MAX($C$8:$C$38)))) En este caso se calcula los dias laborables, del total de dias obtenidos en la celda H3. En principio, para ubicar la fecha inicio, se emplea la funcion SI, donde se determina que como prioridad se emplea la fecha opcional. La segunda fecha que compone la funcion DIAS. LAB, se obtiene empleando la funcion estadistica MAX, aplicada al rango C8:C38, donde la funcion extrae la fecha mayor, es decir la ultima de las fechas que queremos obtener.

Por ultimo se anida toda la formula, empleando nuevamente la funcion SI, donde se determina, que en caso de no existir fecha en la celda C8, se coloque celda vacia. Celda H5=SI(H4=””;””;H3-H4) HOJA DE CALCULO 5 PRACTICA 14 CALCULO DE DIAS LABORABLES, INCLUYENDO LOS FERIADOS ANUALES Vamos a seguir trabajando con la misma fecha de inicio, que se empleo en el ejercicio anterior, produciendo el enlace correspondiente, es decir en este caso la misma fecha opcional y la cantidad de dias agregados. A esa fecha a parte de considerar sabados y domingos, le incorporamos los feriados nacionales considerados en el pais.

Para ello se prepara rango de feriados. Lo expuesto lo vamos a desarrollar a continuacion de la planilla anterior, en un rango de celdas, que abarca A44:I 59. Dentro del rango B45:B53, se ubican los feriados, y en A55:I 59 se desarrolla el ejercicio: A 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 22-ago-02 jueves 22 8 2002 68 Fecha Actual Fecha Opcional 17/05/02 viernes B C D E F G H I feriados anuales no laborables 01-ene-02 ano nuevo 29-mar02 01-may02 25-may02 20-jun-02 viernes santo dia del trabajo revolucion de mayo dia de la bandera 09-jul-02 dia de la independencia 17-ago- muerte de S.

Martin 02 12-oct-02 Dia de las Americas 25-dic-02 Navidad Dia 17 Mes 5 Ano 2002 Dias labor. Celda C55=C2 Esta celda se vincula con la celda origen C2 donde se incorpora la fecha opcional. Celda C57=SI(C55>0;””;HOY()) La funcion SI condiciona a poner celda vacia en caso de que exista fecha opcional. Celda C59=SI(C55>0;C55+$D$6;C57+$D$6) 6 HOJA DE CALCULO PRACTICA 14 En este caso como se puede apreciar, se emplea el incremento de dias empleado anteriormente, por lo tanto se obtiene una fecha que coincide con la primer fecha de las 20 obtenidas en el ejercicio anterior.

Celda F55=SI(ESERROR(DIA(C55));””;DIA(C55)) Celda G55=SI(F55=0;””;MES(C55)) Celda H55=SI(F55=0;””;ANO(C55)) A las tres celdas se le asigna Conditional Formating Valor de la celda Mayor que E 55 Formato Se le asigna color a la fuente y recuadro a la celda Celda F57=SI(ESERROR(DIA(C57));””;DIA(C57)) Celda G57=SI(F57=0;””;MES(C57)) Celda H55=SI(F57=0;””;ANO(C57) A las tres celdas se le asigna Condicional Formating Valor de la celda Mayor que E 57 Format Se le asigna color a la fuente y recuadro a la celda Celda F59=SI(ESERROR(DIA(C59));””;DIA(C59)) Celda G59=SI(F59=0;””;MES(C59)) Celda H59=SI(F55=0;””;ANO(C59)) Celda I 59=DIAS.

LAB(SI(C55>0;C55;C57);C59;B45:B53) Dentro de la funcion empleada para obtener el total de dias laborables, se incluye el argumento de feriados anuales, aparte de los sabados y domingos. El resultado obtenido entre las fechas consideradas, marca una diferencia de dos dias menos laborables con respecto a igual periodo del ejercicio anterior. Esto se debe a que en este caso, dentro del periodo considerado se incluye como no laborables, 20 de junio y 9 de julio. HOJA DE CALCULO 7 PRACTICA 14 CALCULAR DE UNA FECHA DADA, EL PRIMER LUNES DE LA SEMANA A QUE CORRESPONDE Y EL LUNES SIGUIENTE, PARTIENDO DE LA FECHA ORIGINAL DADA

En este ejercicio, partiendo de un numero de fechas especificadas, se determinara en primer lugar la fecha de comienzo de la semana a que corresponde la fecha, considerando como comienzo el dia lunes. Como segunda operacion, partiendo siempre de la fecha origen, el comienzo de la semana siguiente a la fecha dada. Para realizar el ejercicio, se prepara una planilla de Rango A63:E94, se crean cuatro columnas, con el titulo de: Fecha determinada, dia que corresponde, 1° dia de la semana; Lunes siguiente, obteniendose el siguiente resultado que se ira explicando paso a paso A 63 64 65 66 67 68 69 70 71 2 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 B Fecha determinada 19-may-02 21-may-02 23-may-02 25-may-02 27-may-02 29-may-02 31-may-02 02-jun-02 04-jun-02 06-jun-02 08-jun-02 10-jun-02 12-jun-02 14-jun-02 16-jun-02 18-jun-02 20-jun-02 22-jun-02 24-jun-02 26-jun-02 28-jun-02 30-jun-02 02-jul-02 04-jul-02 06-jul-02 08-jul-02 C D E Lunes siguiente 20-may-02 27-may-02 27-may-02 27-may-02 03-jun-02 03-jun-02 03-jun-02 03-jun-02 10-jun-02 10-jun-02 10-jun-02 17-jun-02 17-jun-02 17-jun-02 17-jun-02 24-jun-02 24-jun-02 24-jun-02 01-jul-02 01-jul-02 01-jul-02 01-jul-02 08-jul-02 08-jul-02 08-jul-02 15-jul-02 8 ia que 1° dia de la corresponde semana domingo martes jueves sabado lunes miercoles viernes domingo martes jueves sabado lunes miercoles viernes domingo martes jueves sabado lunes miercoles viernes domingo martes jueves sabado lunes 13-may-02 20-may-02 20-may-02 20-may-02 27-may-02 27-may-02 27-may-02 27-may-02 03-jun-02 03-jun-02 03-jun-02 10-jun-02 10-jun-02 10-jun-02 10-jun-02 17-jun-02 17-jun-02 17-jun-02 24-jun-02 24-jun-02 24-jun-02 24-jun-02 01-jul-02 01-jul-02 01-jul-02 08-jul-02

HOJA DE CALCULO PRACTICA 14 90 91 92 93 94 10-jul-02 12-jul-02 14-jul-02 16-jul-02 18-jul-02 miercoles viernes domingo martes jueves 08-jul-02 08-jul-02 08-jul-02 15-jul-02 15-jul-02 15-jul-02 15-jul-02 15-jul-02 22-jul-02 22-jul-02 La presente planilla se encuentra ejecutada a continuacion de lo desarrollado hasta el momento, permitiendo emplear datos que se obtienen de operaciones anteriores.

La columna de titulo Fecha determinada , permite incluir 31 fechas. Esas fechas son trasladadas de las celdas que trabajan con los Botones de control, es decir en primer lugar colocamos 31 en la celda B6 mediante el Control de numeros, es decir se obtiene el maximo de nuevas fechas, y 2 en la celda D6, mediante la Barra de desplazamiento que corresponde al incremento en dias entre fechas.

Por lo tanto en la celda B64 se traslada la fecha de la celda C8 Celda B64=C8 Se traslada hasta la celda B94 Celda C64=D8 Se traslada hasta la celda C94 Celda D64=SI(B64=””;””;B64-DIASEM(B64;3)) La formula comienza con la aplicacion de la funcion SI, donde determina que si la celda donde contiene la fecha origen se encuentra vacia, devuelva celda vacia. Esto se realiza para poder emplear la planilla elaborada en forma parcial sin que de error, al no encontrar dato.

En la segunda parte de la formula, a la fecha origen se le resta la funcion DIASEM, de esa misma celda con el parametro tipo 3, donde en ese caso devuelve valor 0 ( cero), para el dia lunes y 6 para el dia domingo, por lo tanto como se verifica en este caso, al dia domingo que corresponde a la fecha de la celda B64, que devuelve 6 la funcion DIASEM tipo 3, se le resta la misma funcion, dando como resultado 0 (cero), que corresponde al dia lunes.

La formula se traslada hasta la celda D94 y produce el mismo efecto. Celda E64=SI(B64=””;””;B64+SI(RESIDUO(-DIASEM(B64;3);7)>0;RESIDUO(DIASEM(B64;3);7);7)) Se emplea la funcion RESIDUO para obtener los dias que se deben agregar a la fecha de la celda B64, para obtener el lunes siguiente de la misma. Aplicado de esta manera se puede observar que la funcion devuelve 0 (cero) para lunes, 6 para martes, 5 para miercoles y asi sucesivamente.

La funcion SI se aplica en primer lugar para determinar que en caso de no existir ninguna fecha en la celda B64, devuelva celda vacia, y en segundo lugar, para determinar que en caso de que la funcion RESIDUO devuelva un valor menor o igual a cero, como el dia lunes, devuelva el numero 7 La formula se traslada hasta la celda E94 HOJA DE CALCULO 9