7 Pasos Para Programar

7 Pasos Para Programar gy uasrÑE Cleopa,nR 10, 2016 pagcs Universidad Mariano Gálvez Centro Regional Villa Nueva Ingeniería En Sistemas «B» Ing.

Roxana Díaz Algoritmos Vasty Mazariegos carné: 509015584 1) Definición del Problema: Escriba un programa que permita elegir entre opciones 1) vector edad 2) cadena nombre y apellido 3) mostrar datos según casilla 4) 0 para salir El tipo vector permitirá el in reso de las edades para los alumnos con un máximo de 1 ors S»ipeto El tipo cadena permit de de los apellidos en ar los i Se preguntara al usu se mostrara el nomb re de los alumnos y illa desea ver y iente de manera concatenada y a la vez la edad corresponde al mismo número de casilla. ) Análisis del Problema: La información necesaria para poder ejecutar este programa es conocer las instrucciones correctas que permita el funcionamiento del programa requerido y su manera de empleo como también los datos ingresado por el usuario. 3) Diseño de algoritmo Definir Cont, aux, digito,pot, i como Real Escribir «Ingrese un numero entero positivo:» Leer n cont <- 0 aux <- n digito*pot Escribir "El digito " i," es ",digito

FinPara FinProceso 4) Codificación: cont 0 aux n Mientras

Lo sentimos, pero las muestras de ensayos completos están disponibles solo para usuarios registrados

Elija un plan de membresía
aUX>O hacer cont <- cont + 1 aux trunc(auWIO) FinMientras Escribir "El numero tiene ",cont," digitos" aux<-n para i<-l hasta cont Hacer pot IOA(cont-i) digito <- trunc (aux / pot) aux aux - digito*pot Escribir "El digito ",i," es ",digito 5) Prueba & Depuración: Sintaxis: Estas se realizan con ayud dor hasta que no se muestren errores en el có ",cont," digitos" // Luego, mostrarlos uno por uno Para i<-l hasta cont Hacer pot <- IOA(cont-i) // por cuanto hay que dividir para obtener l primer digito digito <- trunc (aux / pot) // obtener el digito aux aux - digito*pot // quitar ese digito al numero Externa: Manual de Uso Para poder utilizar de manera satisfactoria el siguiente programa lo ayudara a poder identificar cuantos d[gitos tiene el número que usted desee ingresar a continuación se le presentan una serie de pasos a realizar. 1)-. Abra el programa ejecutándolo dándole Click derecho abrir/ ejecutar o bien dándole doble click de manera continua. )-. El programa le desplegara una pregunta la cual debe de ontestar, y a su vez presionar enter para que el programa pueda continuar con su funcionamiento. 3) El programa automáticamente le indicara cuantos dígitos exactamente tiene el numero ingresado por puede usted mismo. 4) automáticamente, al darle el resultado puede salir del programa o bien seguir ingresando números para poder averiguar sus dígitos. 7) Mantenimiento: Si usted se encuentra inconforme con nuestro empleo del programa o bien desea que agreguemos algún cambio por favor permítanoslo saber para p nuestro sistema y este 31_1f3 pueda ser de su agrado pri y de su utilidad.